Degraded performance in US environment

Incident Report for Elastic Path

Resolved

This issue has now been resolved
Posted Aug 19, 2022 - 20:48 UTC

Update

We are continuing to investigate this issue.
Posted Aug 19, 2022 - 20:44 UTC

Investigating

We are currently experiencing degraded performance in the US environment. Our engineers are currently working on the issue.
Posted Aug 19, 2022 - 20:44 UTC
This incident affected: US (US Admin API, US Commerce Manager, US Webhooks).