Degraded performance - Elevated Errors

Incident Report for Elastic Path

Resolved

The incident has been resolved.
Posted Mar 19, 2026 - 16:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 16:42 UTC
This incident affected: US (US Admin API) and EU (EU Admin API).