Degraded Performance Webhooks

Incident Report for Elastic Path

Resolved

The issue has been resolved. No customer Impact after review
Posted Jul 29, 2025 - 22:57 UTC

Investigating

We are currently investigating this issue.
Posted Jul 29, 2025 - 22:05 UTC
This incident affected: EU (EU Webhooks).