Commerce Manager Degradation
Incident Report for Elastic Path
Resolved
The Commerce Manager dashboard is now fully operational.
Netlify has now resolved their degraded performance issue.

Netlify's latest update:
Resolved - Service has been stable for over an hour now. Team continues to monitor closely and we will be posting a public write up about the incident as soon as we can. If any further large scale issues occur, we will open a new incident on our status page.

Please see Netlify's status page for more information on their service health - https://www.netlifystatus.com/
Posted Mar 09, 2022 - 17:37 UTC
Update
Commerce Manager may be experiencing some degraded performance due to degraded performance on Netlify.
Please see Netlify's status page for more information on their service health - https://www.netlifystatus.com/

Netlify's latest update (16:43):
We have not observed further substantial errors in the past 45 minutes. Our team continues to monitor closely and work on additional mitigations. We will be writing a public root cause analysis describing what led to the issue and how we've resolved it.
Posted Mar 09, 2022 - 17:02 UTC
Update
Commerce Manager may be experiencing some degraded performance due to degraded performance on Netlify.
Please see Netlify's status page for more information on their service health - https://www.netlifystatus.com/

Netlify's latest update:
We have been stable (few errors, but latency still higher than usual) since our last status update 30 minutes ago, but the team continues to work on the situation and add new mitigations. We will continue to provide updates as the situation develops.
Posted Mar 09, 2022 - 16:23 UTC
Monitoring
Commerce Manager may be experiencing some degraded performance due to degraded performance on Netlify.
Netlify claim that the degradation has been mitigated. Netlify are continuing to monitor.
Please see Netlify's status page for more information on their service health - https://www.netlifystatus.com/
Posted Mar 09, 2022 - 15:10 UTC
Update
Commerce Manager is experiencing some degraded performance due to degraded performance on Netlify.
Please see Netlify's status page for more information on their service health - https://www.netlifystatus.com/
Posted Mar 09, 2022 - 14:33 UTC
Investigating
We are currently investigating this issue.
Posted Mar 09, 2022 - 14:14 UTC
This incident affected: EU (EU Commerce Manager) and US (US Commerce Manager).